うちのMacの不思議な不具合、起動の遅さと、Magic Mouse2の不具合が解決

| 0件のコメント

ググってみても全く問題ない方の方が多いようで、多分固有の問題。でも原因がなかなか掴めずにいた問題が解決。

SSDなのにMacの起動が遅い

これ、iMacの頃からずっと悩んできた。ので数年悩んでたんだが、やっと解決・・・ふぅ。。。最初に書いておくと

【原因はシンボリックリンク】

うちのMac mini 2018はSSD256GBなので大きめのデータや大きめのシステムデータはUSB外付けの1TB SSDに逃している。多くはアプリで設定できるがLogic Pro Xのライブラリがかつてはシンボリックリンクで逃していた。この状態だと起動するまでになぜかすごく時間がかかって(数分)いた。なんで? システムが外付けにあるからだろうかとか、外付けSSDをつけているからだろうかとか、いろいろやってみても解決せず、でもやっぱ一外付SSDを外すと起動は速い。しかしその環境で問題ない人の方が多いようで、諦めていたら・・・

Logic Pro Xがそういえばライブラリの移動がアプリからできるようになったのを思い出して、シンボリックリンクを切って、一旦メインの内蔵SSDの本来の場所に戻したあと、Logic Pro Xのメニューからライブラリの移動を外付けSSDにし直した。そしたら、起動が速いじゃん! こ・・・これだけの原因だったの? 何度起動してみても同じく速くなっているので、間違いではない・・・。んとに、もぉ・・・。

Magic Mouse2がいつからかちゃんと動かなくなった

これも困っていた。あまりに困ってアップルサポートとしばらくやりとりするも解決せず。ドラックすると1秒遅れて始まり途中でとまりまた動く、とか、ゆっくり動かしても動かないとか、クリックしたのにクリックされないとか、Magic Mouse2が壊れたのかと思って初代Magic Mouseに接続しなおしても同じ。タイミングによっては問題なく動く時もあるし、全然ダメな事もある。もうお手上げ状態で諦めていたら、これもひょんなことから原因判明。

問題は上の写真の、Aukey製のUSB-Cタイプのハブだった。うちでは同じくAukeyのUSB3.0ポートが4つのも合わせて2個使っていたが、なにかのおり、この製品のレビューを見ていたら「この製品をつかうと電波障害が出る」というのを見つけて、「もしや・・・」と思ったらビンゴ! 外した途端にMagic Mouse2がばっちり復活。そういえばこれをつけたあたりから不調になったんだったよなぁ。まさかハブが原因だとは思わないもんなぁ。。。

そういえばもうひとつのUSB3.0が4ポートの方は不安定でよく接続が勝手に外れたり、差し直すとMacが強制再起動したりしてたので、AukeyのUSB Hubは全て撤去し、UGREEN製のを追加購入。TUNEWAREと合わせても問題なく使えてます。ふぅ。。。

ちなみにエレコムの USB Type c USB3.1Gen2ハブ、HC-A424P10BKは特にMacユーザにはオススメしません。USB2.0程度の速度しか出なかったり、安定しなかったりと、まるで使えませんでした。(単に初期不良の可能性もありますが)

この手の製品は速度や安定性を求めるなら多少高くてもTUNEWAREやBelkinなどがやっぱり安心かも、です。

コメントを残す

必須欄は * がついています


CAPTCHA


%d人のブロガーが「いいね」をつけました。